TOAI User Manual

Download the TradeOptimaAl software from the Login page
Load your strategy on to NinjaTrader chart
Select Your strategy, set your parameters
Login to TOAIl on NinjaTrader
a. Username and Password was sent to you via email when you signed up for a

PowObd =

subscription.
Properties
v 00. TOAI Parameters
TOAIMode

01. Write TradeOptimaAl File

02. Use TradeOptimaAl

04. TradeOptimaAl Weights File

TOAI License Password your passsword
TOAI License Email your email
5. TOAI Mode
a. DayOrScalp or Swingin Drop Down menu

v 00. TOAI Parameters
01. Write TradeOptimaAl File
02. Use TradeOptimaAl ]
04. TradeOptimaAl Weights File scalp 1217.csv
05. Probability of Win Min (=) % [0 ]
06. Probability of Win Limit (<) % 100

b. Check Write TradeOptimaAl box
v 00. TOAI Parameters

TOAIMode

02. Use TradeOptimaAl

04. TradeOptimaAl Weights File scalp 1217.csv

06. Probability of Win Limit (<) % 100




c. Enable and Apply Back Test

i.  BestPractice Considerations- Back Testing:

I.

Ii.

fii.

iv.

Sample Size: Ensure focus is on number of trades instead of
number of days to analyze and optimize strategy performance
beyond random chance.

Market Regime Changes: Test strategies across different
market conditions: bullish, bearish, sideways/consolidating,
periods of high/low volatility, seasonality and news events.
Significant regime changes may affect model performance.
Avoid Curve Fitting: Curve fitting occurs when a trading model
is overly optimized to historical data capturing noise instead of
capturing underlying patterns to categorize probability of wins
and losses in the software. The strategy will perform well in
back tests but fail in live markets with curve fitting.

Transaction Costs: Include realistic slippage, commissions,
and bid-ask spreads in back tests, as futures markets can have
significant transaction costs that impact strategy profitability.

ii. Best Practice Considerations - Forward Testing:

General: Forward testing is a critical step in validating your
strategy with the TradeOptimaAl file after back testing. Forward
testing means running your automated trading strategy
embedded with TradeOptimaAll file on live market data in real-
time, but with simulated trades rather than actual money.

. Market Conditions: Forward test through different market

regimes as trending, ranging, news events and volatile periods
all behave differently.

Execution Reality: Pay attention to order fills, especially for
strategies requiring quick execution. Futures markets can have
significant slippage during volatile periods.

Sample Size: Ensure you have enough trades during the
forward testing period to draw meaningful statistical conclusions
about your strategy's performance in different market conditions.

6. TradeOptima Al Program

a.

Open TradeOptimaAl Software Program
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b. Load Training File

i.  File>Open > Training File > Documents > Double Click on Trade

OptimaAl > Double Click on Your Strategy Name > Training Data >

7 k3 Trader TradeOptimaAl v1.( X El=
< = o b (&} @ Start backup > TradeOptimaAl > k3 Trader TradeOptimaAl v 1.0.2i111624 >
@ New ~ *» O oo @ W N oSort~ = View -
£ Home Name Date modified Type Size
) Gallery | __ TrainingData 12/18/2024 9:29 AM File folder
T Weights 12/18/2024 8:21 AM File folder

> @ OneDrive

G Desktop
4 Downloads
| Documents
P9 Pictures
@ Music

3 Videos

LR TR T S T

T2 Event

T Screenshots
. TrainingData

7 Weights

2items  1item selected

(=] x

Search k3 Trader TradeOptimaAl Q

(B Details




Select the desired Training Data Test > Open

ol Open
<« > v <« TradeOptimaAl > k3 Trader TradeOptimaAl v 1.0.2i111624 > TrainingData v C Search TrainingData
Organize v New folder =
A Name Date modifi;':’d Type Size
| [] k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/18/2024 9:30 AM CSV File 14KB
E] Gallery
[] k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/18/2024 9:25 AM CSV File 14KB
> @ OneDrive
D k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/18/2024 9:19 AM CSV File 12KB
D k3 Trader TradeOptimaAl v 1.0.2i1111624_...  12/18/. CSV File 5KB
@ Desktop  # [ k3 Trader TradeOptimaAl v 1.021111624_...  12/17/ CSV File 1KB
+ Downloads # [] k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/17/2 CSV File 11KB
— Documents # D k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/17/ CSV File 13 KB
PN Pictures » D k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/9/2024 2:42 PM CSV File 14 KB
’ [] k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/2/2024 2:42 PM CSV File 14KB
@) Music @
[] k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/2/2024 11:20 AM CSV File 14KB
i3 Videos #
I:] k3 Trader TradeOptimaAl v 1.0.2i111624_...  11/21/2024 11:52 AM CSV File 15KB

File name: ‘ k3 Trader TradeOptimaAl v 1.0.2i111624_NQ_3 Minute_20241218_09029022.csv

Cancel

c. LoadTest File

File > Open > Test File > Documents > TradeOptimaAll > Double Click on
the Your Strategy Name > Training Data >

~ k3 Trader TradeOptimaAl v1.C X ar

<« > 2

@ New ~ %

£ Home
PR Gallery

> @ OneDrive

@M Desktop  #
L Downloads #

] Documents +

P9 Pictures »

@ Music »

3 Videos +
Event
Screenshots

TrainingData

Weights

2items

1 item selected

(] % Startbackup > TradeOptimaAl > k3 Trader TradeOptimaAl v 1.0.2i111624
18] @D i ML Sort = View -
Name Date modified Type Size
[ TrainingData 12/18/2024 9:29 AM File folder
Weights File folder

>

a X

Search k3 Trader TradeOptimaAl Q

(B Details




ii. Selectthe desired Training Data Test > Open

—
ol Open X
€ v <« TradeOptimaAl > k3 Trader TradeOptimaAl v 1.0.2i111624 > TrainingData v C Search TrainingData P
Organize v New folder =~ O 0
A Name Date modified Type Size
| [] k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/18/2024 9:30 AM CSV File 14KB
) Gallery
D k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/18/2024 9:25 AM CSV File 14 KB
@ OneDrive
D k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/18/2024 9:19 AM CSV File 12KB
D k3 Trader TradeOptimaAl v 1.0.2i1111624_...  12/18/2024 9: CSV File KB
@ Desktop [ &3 Trader TradeOptimaAl v 1.0.21111624_...  12/1 SV File 1 KB
+ Downloads # [7] k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/17/202 CSV File 11KB
—| Documents D k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/17/202 CSV File 13 KB
PN Pictures D k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/9/20 CSV File 4KB
R D k3 Trader TradeOptimaAl v 1.0.2i1111624_...  12/2/2024 2:42 PV CSV File 14 KB
W Music
§ D k3 Trader TradeOptimaAl v 1.0.2i111624_...  12/2/2024 11:20 AM CSV File 14 KB
i3 Videos
D k3 Trader TradeOptimaAl v 1.0.2i111624_...  11/21/2024 11:52 AM CSV File 15KB
File name: ‘ k3 Trader TradeOptimaAl v 1.0.2i111624_NQ_3 Minute_20241218_09029022.csv v
—
d. Calculate Decision Boundary and Predictive Model Value (“PMV?”)

i. Select Features that you want to the TradeOptima Al to apply to your
Strategy and click “Calculate Decision Boundary.”

ii. Features Description

®Momentum 1A (Fast)- Trend following indicators used in technical
analysis to help traders identify changes in the strength, direction,
and duration of trend in a financial instrument.

®Momentum 2A (Slow)- Trend following indicators used in technical
analysis to help traders identify changes in the strength, direction,
and duration of trend in a financial instrument.

®Momentum 3A- Identify overbought and oversold conditions and
momentum shifts in the market

®Momentum 4A- versatile technical analysis indicator that
measures the deviation of the price from its average price.



@®Support and Resistance 1B1 and 1B2 - Key concept in technical
analysis that are used by traders to quantify support and resistance
from current price to swing high/low.

@®Support and Resistance 1B3 - Key concept in technical analysis
that are used by traders to quantify support and resistance from
average price from swing high/low.

@®Trend (1C) - Identify the direction and strength of a market trend.
These indicators help traders determine whether a market is in an
uptrend, downtrend, or moving sideways, and they can be used to
make decisions about entering or exiting trades.

@®Trend (2C)- Stacked moving averages of multiple moving averages
plotted together from shorter to longer time periods to identify
uptrends, downtrends or no trends.

@®Trend (3C) - Indicator is used to identify support and resistance
levels, trend direction, momentum, and potential reversal points.

@®Volatility 1D- Indicator uses the average true range to identify the
volatility range.

@®Volatility 2D- Indicator uses the standard deviation of price to
identify the volatility range.

®Volume 1E - Indicator identifies high/low volume of financial
instrument traded

Best Practice Considerations - Feature Selection:

e General: Traders should consider selecting a feature to
evaluate one at a time by using our predictive model value
(PMV) score. Traders then add each new feature to a set of
previously tested features, each time evaluating a new PMV
score.

e Avoid Curve Fitting: Selecting less features is generally better
than more to embed in your strategy. Too many features often
contain irrelevant or redundant features that can degrade model
performance. By removing these unnecessary features, you can
reduce overfitting, decrease training time and create more
interpretable results that are easier to understand.



e Market Conditions: Different features may work better in
different market regimes: trending vs. ranging markets, high/low
volatility markets, seasonal markets and market news events.

iv. Click on “Calculate PMV”

@®PMV represents the probability that a predictive winning
percentage trade would rank higher than a predictive losing trade
into an easy-to-understand single number score.

@®Example: a PMV of .65 means the machine learning model has a
65% chance of correctly distinguishing between winning and

losing trades.

o5 TradeOptimaAl V1.03

File  Export
Features

OTF

() DateTimeOf Entry

(J PnL

() ProbOfTrue
() TradeDirection
() Momentum-1A
() Momentum-2A
() Momentum-3A
Momentum-4A
() Trend-1C
Trend-2C

(] Trend-3C

Support Resistance-1B1
() Support Resistance-1B2
() Support Resistance-1B3

Volatility-1D
Volatility-2D
Volume-1E

Calculate Decision
Boundary

Caleul

PMV: 0.69

Output

Momentum-4A Trend-2C g‘;@gj’:ﬂce_1 gy Volatity-1D Volatilty-2D Volume-1E

UL R i -0.83502880140... |0.121115236905... | 0.197696389080... |-0.20002119978... |-0.00081826735...
-2.18757643687... |-1.19756348322... | 8.256599463015... |5.058261330176... |-4.99947006146... |-1222.09446351...

TRADE
OPTIMAL.AI

ate PMV

Number of True Datapoints: 42
Number of False Datapoints: 64

Loaded Test File

C:\Users\David\Documents\TradeOptimaAl\k 3 Trader TradeOptimaAl v 1.0.21111624\TrainingDatak3 Trader TradeOptimaAl v 1.0.21111624_NQ_3 Minute_20241218_09029022 csv

Number of True Datapoints: 42

Number of False

Datapoints: 64

99%




e. Export Weighted File

i. Export>Weights >

85 TradeOptimaAl V1.03

(O /A TOAI

(J Pl Momentum4A  Trend-2C Supot gy Volatity-1D Volatilty-2D Volume-1E

al -0.83502880140... [0.121115236905... |0.197696383080... |-0.20002119978... |-0.00081826735...
Momentum-1A

() Momentum-2A -2.18757643687... |-1.19756348322... |8.256599463015... |5.058261330176... |-4.99947006146... |-1222.09446351...
() Momentum-3A .
B Momentum-4A

[ -] Support Resistance-1B1

() Support Resistance-1B2
() Support Resistance-1B3

B Volatiity-1D '
B Volatilty-2D P
& Volume-1E

TRADE
OPRPTIMAL.AI

\\!//

Boundary

Calculate PMV

PMV: 0.69

Calculate Decision // ‘

Output

Number of True Datapoints: 42
Number of False Datapoints: 64

Loaded Test File
C:\Users\David\Documents\TradeOptimaAl‘\k3 Trader TradeOptimaAl v 1.0.21111624\TrainingData‘\k3 Trader TradeOptimaAl v 1.0.21111624_NQ_3 Minute_20241218_09029022 csv

Number of True Datapoints: 42
Number of False Datapoints: 64

999 i)

ii Documents > TradeOptimaAl > Double Click on Your Strategy Name >

Weights
B Save As
< > S T « Documents > TradeOptimaAl > k3 Trader TradeOptimaAl v 1.0.2i111624 ~ &) Search k3 Trader TradeOpti... QO
Organize ¥ New folder = v (2]
~
@) Music » Name Date modified Type Size
n Videos » 7 TrainingData 12/18/2024 9:29 AM File folder
- "~ Weights 12/18/2024 8:21 AM File folder
—0 Event
7 Screenshots

7 TrainingData

© Weights

> [ This PC

> 3 Network

File name:

Save as type:

~ Hide Folders Save ) ) Cancel




iii.  Name your Weighted File
@®Note: Weighted files mustend in.csv

a7 Save As X

€ R <« TradeOptimaAl > k3 Trader TradeOptimaAl v 1.0.2i111624 > Weights y Search Weights P

]
19

Organize ¥ New folder
) Music Name Date modified Type Size
i3 Videos D 3 min scalp v2.csv 12/2/2024 2:41 PM CSV File
Event
Screenshots
TrainingData

Weights

s ——

[ This PC

3 Network

File name: | scalp 1217.csv

Save as type:

A Hide Folders Save Cancel

7. Run Back Test with Weighted File
a. Right Click > Strategies > Scroll down to TOAI Parameters > Check “Write
TradeOptimaAl File > Check “Use TradeOptimaAl”
b. Choose TradeOptimaAl Weighted File in Dropdown menu
c. Input “0” in Probability of Win Min (>) %

v (0. TOAI Parameters
TOAIMode
01. Write TradeOptimaAl File

02. Use TradeOptimaAl

04. TradeOptimaAl Weights File 3 min scalp v2.csv

d. Enable Strategy
e. Click Apply




8. Analyze Back Test with Weighted File Applied
a. Documents Folder > TradeOptimaAl > Double Click on Your Strategy Name >
Training Data > Select the Training Data Test > Right Click > Open With a
Spreadsheet software

- =
X |+ e o<

C & OneDrive > -+ k3 Trader TradeOptimaAl v 1.0.3a.120724 > TrainingData Search TrainingData Q

© @&D = \mj N Sort = View (B Details
Name Status Date modified Type Size

B3] k3 Trader TradeOptimaAl v 1.0.32.120724 - e . T A C. 7K8

% © @ @ W

£ k3 Trader TradeOptimaAl v 1.0.3a.12072 g 2
Cut Copy  Rename  Share Delete

£ k3 Trader TradeOptimaAl v 1.0.3a.12072 c 8 K8
ﬁ Open Enter

-
§e Open with > 3l Excel

7vm

3] k3 Trader TradeOptimaAl v 1,0.32.12072¢

9] k3 Trader TradeOptimaAl v 1.0.32.12072¢

. - & Share @ Search the Microsoft Store
E37) k3 Trader TradeOptimaAl v 1.0.32.12072¢

g

Add to Favorites I h
£33 k3 Trader TradeOptimaAl v 1.0.32.12072¢ Cheoseanctherapp;

g

Compress to... b
ED k3 Trader TradeOptimaAl v 1.0.3a.12072« (e 9K8

Copy as path Ctrl+Shift=C

s 8

Properties Alt=Enter

g Always keep on this device

» Free up space

o

OneDrive

Edit in Notepad

Share with Skype E' =

@

ted 6.14KB  Sync pending

&

Show more options

b. Select “ProbOfTrue” in Column D > Data > Sort by Lowest to Highest (If you
get a prompt to “Expand the selection”, make sure it is selected to sort)
i. The TOAI model will output a Probability of True score between 0 and
100.
1. The Probability of True used by TOAI refers to the predicted
probability that a given trade will be a winning or losing trade.
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c. Determine Your Probability of Win Minimum

= \ m T N N & Jusen & Cormechons A y <7 =R - 2% o f |
GEE B B R [E | RS- TR AR < B EB 43 40 o
m
TF kDire Momentut 2y Volatility-Volume-1E
-1 -1 [ -ME 1nes1
3 1 1 1 %7
4 1 1 [ 209
s 1 1 1 2628
b 1 1 1 4,0
& 1 1 1 €520
Q 1 1 1 5217
0 1 1 0 2051
1 -1 -1 0 1088
-1 -1 0400427 TG
3! 1 1 1 a5
& 1 1 03 e
5 1 1 1
e[ 1 1 s
7 1 1 3
B 1 1
gl 1 1
20, -1 -1
a 1 1
22 -1 -1
2; 1 1
22 1 1
25 1 1
% 1 1
2r| -1 -1
28 16 bl 1 1 20 =
20 2783 -1 -1 2 o8
30| 2783 1 1 -2 03665
31 2783 1 1 2 °
32| 015 1 1 2 0217154
) 2783 1 1 2 1
16| 1 1 2 0
2083 00| 1 1 Z b
2783} 0 -1 -1 7 01651028
~M16| 27 -1 -1 2 <
Optiman! v1.0. +
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Sum Column C to calculate the PnL of the back test without any TOAI
filtering applied to find your baseline. In the example above, the PnLin
this particular strategy was $6,222 with 114 trades.

1.

Note: In most spreadsheet programs, you can view the sum of
selected cells at the bottom right of your spreadsheet.

Average: 55.0619469 Count: 114 Sum: 6222

Identify the Probability of True Minimum that yields the most amount
of predictive profit by summing the PnL in Column C of only the
corresponding trades that score at or above the Probability of True in

Column D. The lowest number in that range of Column D is your
Probability of Win Minimum.

1.

Practice Tip- Traders may consider to start at Probability of
True of 50, calculate total corresponding PnL in Column C and
compare it to the baseline results. Repeat this calculation with
different Probability of True values to find the number that
works best for the particular strategy. Generally, Traders will
want to find the number that yields the most amount of
predictive profit, less number of trades from baseline testing



and desired strategy performance results. TOAI will filter your
trading strategy to only take trades that score in excess of the
Probability of True Minimum.

B (< D E F G H
7/16/2025 10:35 395 40 -1 -1 -2 0.188691
7/24/2025 12:59 -124 40 -1 -1 -2 0

7/9/2025 12:37 -79 41 1 1 -2 1
7/31/2025 10:13 395 42 -1 -1 -2 0
7/9/2025 14:59 -114 44 1 1 -2 0.986383
7/28/2025 12:20 -134 44 -1 -1 -2 0
7/30/2025 14:32 -189 44 1 1 2 0.796363
71212025 9:57 -404 45 -1 -1 -2 0.145833
7/8/20259:32 395 46 1 1 -2 1
7/9/2025 14:22 -99 47 L 1 -2 1
7/10/2025 14:49 395 48 -1 -1 -2 0
71712025 9:54 395 49 -1 -1 -2 0
7/9/2025 14:53 -404 49 -1 -1 -2 0
7/2/2025 11:48 -74 50 -1 -1 -2 0
71712025 8:50 395 50 1 1 2 0.710695
7/15/2025 11:57 395 50 -1 -1 -2 0
7/24/2025 11:02 125 50 -1 -1 2 0
7/30/2025 13:28 395 51 1 1 2 1
7/15/20259:01 -404 52 -1 -1 -2 0
7/16/2025 13:25 395 52 1 1 2 0.791677
7/23/2025 12:26 395 52 1 1 -2 1
7/18/2025 8:40 30 53 -1 -1 2 0
7/14/2025 14:34 165 54 -1 -1 -2 0.161716
7/22/2025 13:18 -404 54 -1 -1 -2 0
7/30/2025 10:01 395 55 -1 -1 2 0
7/2/2025 10:13 395 56 -1 -1 -2 0.027442
7/16/2025 14:41 -129 56 1 1 -2 1
7/10/2025 10:25 395 57 1 1 2 1
7/24/2025 11:29 -44 57 -1 -1 -2 0
71712025 8:43 -404 58 1 1 2 0.748845
7/11/2025 10:09 395 59 -1 -1 -2 0
7/18/202510:12| 19 61 1 1 2 1 |
7/23/20259:01 -404 61 -1 -1 -2 0
7171202511:47) B4 62 -1 1 2 0.130091 Average: 114,0972222 Count: 72 Sum: 8215
7/8/20259:01 395 63 -1 -1 -2 0
7/1/20259:16 -404 64 1 1 -2 1
77712025 14:53 395 64 1 1 -2 1




2. Inthe example above, by summing the PnL in Column C of only
the corresponding trades that score at 46 or above, it was
determined that a Probability of True score of 46 would have
yielded the optimal predictive strategy performance results
with a profit of $8,215 and total trades of 72, or 42 less trades
with TOAI filtering software applied to the original back test
results. Therefore, “46” would have been selected as the
value entered on the Probability of Win Minimum and only take
trades that score at 46 or above.

9. Apply Weighted File to Strategy
a. Right Click > Strategies > TOAI Parameters > Check Use TradeOptimaAl
b. Choose Trade OptimaAl Weighted File in Dropdown menu
c. Inputthe value identified from Step 8 in Probability of Win Min (>) %

v 00. TOAlI Parameters
TOAIMode DayOrScalp

01. Write TradeOptimaAl File ]
02. Use TradeOptimaAl

04. TradeOptimaAl Weights File heikentest1.csv
05. Probability of Win Min (=) %
TOAIl License Password

TOAI License Email

d. Enable Strategy
e. Click Apply



